Back to overview
Degraded

StaffIQ Manager Alerts Not Sending

Mar 03, 2026 at 04:08pm UTC
Affected services
App (DataIQ & StaffIQ UIs)

Resolved
Mar 03, 2026 at 07:15pm UTC

We have resolved the issue and manager emails are delivering successfully.

Updated
Mar 03, 2026 at 06:15pm UTC

A fix has been deployed and we are monitoring email sending to confirm the issue is fully resolved.

Updated
Mar 03, 2026 at 05:23pm UTC

Engineering has identified the problem and preparing a fix.

Created
Mar 03, 2026 at 04:08pm UTC

We're investigating an issue with StaffIQ saved search alerts not being sent to managers. Engineering is preparing a fix. We'll share another update shortly.